Installation


  • It's recommended that you read Messenger Platform's Overview before continuing this documentation.
  • Please note that this documentation is for WordPress edition only. If you use Laravel, try Messenger Storm documentation

Site Requirements

In order to run Giga Messenger Bots, your server should meet these minimum requirements:

  • PHP >= 7.1.3
  • WordPress >= 4.8
  • cURL should enabled
  • Your site should be https. Get a free one in LetsEncrypt

Althought the plugin can run on PHP 5.6 but it's highly recommended that you run latest PHP 7 for better performance and security. WordPress itself recommend PHP 7.2 also.

Installing Giga Messenger Bots

Like other WordPress plugins, you just do some simple steps to install.

  1. Download giga-messenger-bots.zip and unzip the package.
  2. Copy giga-messenger-bots directory to /wp-content/plugins directory.
  3. Activate plugin through wp-admin/plugins screen.
  4. Done! Now navigate to Dashboard / Giga AI / Settings page and start configuring and continue reading Setup Messenger documentation.